Degraded Microsoft 365 sync performance
Incident Report for Cronofy
Resolved
From 19:22 to 22:27 UTC calendar sync operations to Microsoft platforms were degraded. During this time around 60% of operations between Cronofy and Microsoft resulted in failure.

We took steps to mitigate the effects of this on other platforms and began monitoring the issue which has now been resolved.

This was a recurrence of an earlier issue, https://status.cronofy.com/incidents/5ftvqz5tp40d.
Posted Jun 05, 2023 - 23:02 UTC
Update
We continue to experience degradation with Microsoft 365 sync operations. We're monitoring our systems closely.
Posted Jun 05, 2023 - 21:29 UTC
Monitoring
We continue to experience degradation with Microsoft 365 sync operations. We're monitoring our systems closely.
Posted Jun 05, 2023 - 20:29 UTC
Identified
We are seeing a recurrence of the earlier issue with Microsoft 365, https://status.cronofy.com/incidents/5ftvqz5tp40d.

We are taking the same steps to mitigate the effects of this on other background processing operations.
Posted Jun 05, 2023 - 19:42 UTC
This incident affected: Background Processing and Major Calendar Providers (Microsoft 365, Outlook.com).