Degraded Microsoft 365 sync performance
Incident Report for Cronofy
Resolved
From 14:13 to 15:47 UTC calendar sync operations to Microsoft platforms were degraded. During this time around 69% of operations between Cronofy and Microsoft resulted in failure and led to a backlog when processing requests.

We took steps to mitigate the effects of this on other platforms and began monitoring the issue which has now been resolved.

We believe this is related to Microsoft alert: MO571683 (https://portal.office.com/adminportal/home?#/servicehealth/:/alerts/MO571683)
Posted Jun 05, 2023 - 16:56 UTC
Monitoring
Calendar sync operations to Microsoft services appear to have returned to normal around 16:00 UTC. We are continuing to monitor.
Posted Jun 05, 2023 - 16:13 UTC
Update
Our telemetry is showing that calender sync operations to Outlook.com and Microsoft 365 are also affected.

We have mitigated the performance impact this issue was having on calendar sync operations with other providers.

We are tracking open Microsoft incidents, with IDs MO571683 and EX571516, and continuing to monitor our platform closely.
Posted Jun 05, 2023 - 15:48 UTC
Identified
We have identified an issue with calendar sync operations when connecting to the Microsoft Graph API.

We are working to mitigate this impact on the rest of our background processing jobs.
Posted Jun 05, 2023 - 14:53 UTC
Investigating
We are currently investigating degraded performance with background processing in both our DE and US data centers.
Posted Jun 05, 2023 - 14:31 UTC
This incident affected: Background Processing and Major Calendar Providers (Microsoft 365, Outlook.com).