Apple calendar sync degraded

Incident Report for Cronofy

Resolved

Since approximately Tuesday June 24th, 18:35 UTC, we saw a much higher than normal number of errors when communicating with Apple's calendar service. Error returned to regular levels at around 23:00 UTC.

These times align with an issue Apple reported with iCloud Calendars and other iCloud services per https://www.apple.com/support/systemstatus/

Sync with Apple calendars may have taken longer both to and from Apple as a result of the underlying errors during this period.
Posted Jun 24, 2025 - 23:43 UTC

Update

We continue to see a much higher than normal number of errors when communicating with Apple's calendar service.

Our retry mechanisms appear to be doing their job, but changes to calendars may take longer to sync both to and from Apple as a result of the underlying errors.

We are still monitoring the situation
Posted Jun 24, 2025 - 20:56 UTC

Monitoring

Since approximately 18:35 UTC we have seen a much higher than normal number of errors when communicating with Apple's calendar service.

Our retry mechanisms appear to be doing their job, but changes to calendars may take longer to sync both to and from Apple as a result of the underlying errors.

We are monitoring the situation.
Posted Jun 24, 2025 - 19:55 UTC
This incident affected: Major Calendar Providers (Apple).