8x8 conferencing requesting moderator login
Incident Report for Cronofy
Resolved
Since launching support for provisioning video conferencing when creating a calendar event in 2020 we have used 8x8.vc links as an explicit option and as an anonymous, browser-based conferencing fallback when calendar-native conferencing providers such as Google Meet and Microsoft Teams are not available.

8x8 accounts for around 1% of the video conferencing we have provisioned in recent weeks, the other 99% being made up of calendar-integrated conferencing solutions like Google Meet and standalone providers like Zoom.

8x8 removed support for 8x8.vc links being used anonymously earlier this week, without any notification and with no available workaround.

Ideally, we would have received prior notification from 8x8 of this change so that we could have managed a graceful transition. As that did not happen, we will regrettably be dropping support for 8x8 as a conferencing option with immediate effect.

When using our API, "8x8" can be selected explicitly, or chosen as a fallback when using the "default" conferencing option. We have released a change which stops the generation of the anonymous, browser-based 8x8.vc conferencing links and so calendar events will be created, but without any conferencing details.

Put another way, "8x8" will have a similar effect to providing "none", and there will no longer be a catch-all conferencing option provisioned when using "default".

https://docs.cronofy.com/developers/api/conferencing-services/create/#param-conferencing.profile_id

We will continue to accept both values to as to not break any existing integrations. "8x8" has been deprecated and the documentation relating to "default" has been updated to reflect this change in behavior.

If you subscribe to notifications based on conferencing being provisioned, you will be notified of the failure to provision any conferencing in cases where 8x8 would previously have been used.

https://docs.cronofy.com/developers/api/conferencing-services/subscriptions/

We truly regret this situation and can only apologize for the disruption this has caused. As there is no further action we are able to take on this, we are resolving this incident.

If you have any further questions, please contact us at support@cronofy.com
Posted Oct 20, 2023 - 17:18 UTC
Update
[Message edited for easier reading]

We announced the changes detailed in the resolution message but in the future tense.
Posted Oct 20, 2023 - 14:59 UTC
Update
We have had a response from 8x8 confirming that this change in service is intentional, will not be reversed, and that there is no workaround for any existing 8x8.vc links.

This is the worst outcome we could foresee and are sorry for any disruption this is causing.

We will be finalizing and sharing our plan for handling this by 15:00 UTC.
Posted Oct 20, 2023 - 13:18 UTC
Identified
Since launching support for provisioning video conferencing when creating a calendar event in 2020 we have used 8x8.vc links as an explicit option and as a fallback when calendar-native conferencing providers such as Google Meet and Microsoft Teams are not available.

These links were previously anonymous, requiring no account to be set up for them to be used. These links no longer support anonymous access, instead users will now be presented with "Waiting for moderator" and an option to login.

There does not appear to be a way for anyone to create an account meaning these 8x8 links are currently unusable with no known workaround.

We did not receive any notice of this change, we first received reports relating to this on Tuesday October 17th, and have since confirmed the change in behavior ourselves.

We have reached out to our contact at 8x8 about this change in their service and are evaluating our options
Posted Oct 20, 2023 - 09:35 UTC