We have released version 0.22.25 of the Cronofy Chrome extension, fixing the issue. If you have any problems, please first check that both Google Chrome and the Cronofy Chrome extension are up to date. If you have any additional issues then please contact support@cronofy.com.
Posted Feb 17, 2026 - 14:10 UTC
Update
We have submitted an updated version of the Chrome Extension to Google which contains a fix for this issue. The updated version will be available as soon as it has been checked and published by Google. We will provide an update once we confirmation of this from Google.
Posted Feb 17, 2026 - 13:34 UTC
Identified
A recent Google Chrome update has changed a mechanism that our Gmail extension relies on. We are developing a fix that is compatible with this new mechanism. We will provide an update in a few hours or when we have an updated version of the extension ready.
Posted Feb 17, 2026 - 12:39 UTC
Update
We are still working to identify the exact root cause of the issue. We will provide further updates as soon as possible.
Posted Feb 17, 2026 - 12:01 UTC
Investigating
We are aware of issues affecting our Google Chrome Extension preventing users from creating scheduling requests in Gmail. We are currently investigating and will provide an update as soon as possible.