Events failing to sync to user calendars

Incident Report for Cronofy

Resolved

At approximately 12:30 UTC a change was released that prevented events being created in Microsoft calendars if integrated conferencing was being used.

A fix was released and the last error observed at approximately 16:05 UTC.

Over 90% of the impacted events were successfully synced due to standard retry mechanisms with the platform by 17:00 UTC, we also ran a sweep to proactively retry all remaining events which completed by 17:30 UTC.

This incident is now resolved and operations are back to normal.

We will be conducting a postmortem and will publish the findings of that next week.
Posted Feb 27, 2026 - 17:35 UTC

Update

At approximately 12:30 UTC a change was released that prevented events being created in Microsoft calendars if integrated conferencing was being used.

A fix was released and the last error observed at approximately 16:05 UTC.

Since that time over 90% of the impacted events have been successfully synced due to standard retry mechanisms with the platform.

We are working to enqueue additional attempts for all affected calendars to speed up this process and to be certain nothing has been missed.
Posted Feb 27, 2026 - 17:00 UTC

Update

We have identified that affected events were those being written to Microsoft calendars and using the `integrated` conferencing option. The system is already retrying these failures and successfully writing them. We are looking to accelerate this process.
Posted Feb 27, 2026 - 16:28 UTC

Identified

Since approximately 12:30 UTC a subset of calendar events failed to be synced to users' calendars.

We've identified the source of the issue and released a fix, we are now assessing the impact and actions necessary to resolve the issue for previously impacted calendar events.
Posted Feb 27, 2026 - 16:06 UTC
This incident affected: Background Processing.