Degraded sync performance for Microsoft 365

Incident Report for Cronofy

Resolved

Between 22:00 and 01:15 UTC we saw elevated error rates when performing sync operations with Microsoft 365.

Microsoft continues to work on a full resolution to the incident with ID MO1221364. However, the error rates we are now observing are back to normal levels.
Posted Jan 23, 2026 - 01:19 UTC

Update

We are continuing to monitor the situation, but have not seen any improvement so far
Posted Jan 23, 2026 - 00:01 UTC

Monitoring

We believe this is related to a Microsoft incident (ID: MO1221364). We are keeping a close eye on how this progresses
Posted Jan 22, 2026 - 23:28 UTC

Investigating

We are currently investigating degraded sync performance for Microsoft 365 as we are experiencing a much higher error rate than normal.
Posted Jan 22, 2026 - 23:18 UTC
This incident affected: Major Calendar Providers (Microsoft 365).