Platform not responding
Incident Report for Cronofy
Resolved
This incident has been resolved.
Posted Nov 05, 2018 - 14:50 UTC
Monitoring
An update has been released to address the identified queries.
Posted Nov 05, 2018 - 13:58 UTC
Identified
The outage was caused by the primary database processing many extremely slow queries at the same time which produced back pressure going all the way back to requests being shed at the web server level.

We've identified a handful of queries that appear to be responsible for this and will be making changes to prevent them from occurring.
Posted Nov 05, 2018 - 12:59 UTC
Update
The API and app were unresponsive for around 3 minutes. Both have resumed normal service and we are investigating the underlying cause.
Posted Nov 05, 2018 - 11:52 UTC
Investigating
We are currently investigating this issue.
Posted Nov 05, 2018 - 11:49 UTC
This incident affected: API, Background Processing, and Developer Dashboard.