Elevated errors from Google Calendar
Incident Report for Cronofy
Resolved
At approximately 17:00 UTC we observed a much higher number of errors for Google calendar API calls than we would expect (mostly 503 Service Unavailable responses) across all of our data centers.

There does not appear to have been a pattern to the accounts affected by this.

We decided to open an incident about this at 17:10 UTC to inform of potential service degradation as it seemed like it could be a more persistent issue. Whilst opening this incident, errors when communicating with the Google calendar API returned to normal levels at around 17:12 UTC.

Errors have remained at normal levels since that time and so we are resolving this incident.
Posted Jan 27, 2022 - 17:34 UTC
Monitoring
Errors returned to usual levels at around 17:12 UTC, as the previous message was being sent.

We are monitoring the situation.
Posted Jan 27, 2022 - 17:18 UTC
Investigating
Since approximately 17:00 UTC we have seen a higher level of errors when communicating with Google calendars than we would normally expect across all of our data centers.

We are monitoring the situation and taking any actions available to us to minimize the impact. Synchronization performance for Google calendars will be affected by this.
Posted Jan 27, 2022 - 17:14 UTC
This incident affected: Major Calendar Providers (Google).