High Apple iCloud failure rates
Incident Report for Cronofy
Resolved
This incident has been resolved.
Posted May 23, 2019 - 18:11 UTC
Update
Seeing signs that the level of errors for Apple iCloud calendars are returning to their normal, minimal level.
Posted May 23, 2019 - 17:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2019 - 17:20 UTC
Identified
Apple's iCloud calendar servers are reporting a high level of errors, this is leading to some degradation in performance of our background processing.

We are altering our polling schedule to reduce the impact for other calendar providers.
Posted May 23, 2019 - 17:00 UTC
This incident affected: Major Calendar Providers (Apple) and Background Processing.