Office 365 accounts disconnected
Incident Report for Cronofy
Resolved
All accounts have been reconnected where possible.
Posted Jul 05, 2018 - 12:16 BST
Identified
A key rotation caused multiple accounts to become disconnected. This seems to be a temporary problem, our working suspicion is that it took some time for the new key to propagate on Microsoft's side which led to false negatives.

We're attempting to reconnect any accounts disconnected during this period in order to re-establish service without users having to do anything.
Posted Jul 05, 2018 - 11:50 BST