Google calendar sync degraded

Incident Report for Cronofy

Resolved

Between 18:15 UTC and 18:28 UTC, we observed elevated error rates, and Google Calendar users may have experienced delays with calendar reads and writes. Since 18:28 UTC, all Google Calendar operations have been functioning as normal.
Posted Nov 12, 2025 - 18:56 UTC

Monitoring

Google's API error rate has dropped again and has been at normal levels for the past 10 minutes.

We'll continue to monitor and confirm this holds out.
Posted Nov 12, 2025 - 18:40 UTC

Investigating

We are currently investigating the cause of Google calendar sync degradation
Posted Nov 12, 2025 - 18:31 UTC
This incident affected: Major Calendar Providers (Google).