Degraded Microsoft 365 sync for US data center
Incident Report for Cronofy
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 02:58 UTC
Update
Errors for 365 calendars have been around normal levels for approximately 20 minutes.

This Twitter thread contains some details of MO234433 and related EX234428 which appear to be the root cause: https://twitter.com/MSFT365Status/status/1349884557747695618

We will look to reinstate credentials where possible shortly.
Posted Jan 15, 2021 - 02:42 UTC
Monitoring
Errors for 365 calendars remain higher, but otherwise systems have returned to normal.

A small number of accounts (less that 1%) may have been incorrectly flagged as disconnected during this period. Once 365 errors have returned to normal levels we will attempt to reinstate credentials that have been flagged during this time.

Microsoft have opened MO234433 "Unable to access multiple Microsoft 365 apps or services" which is potentially related to the errors we have observed.
Posted Jan 15, 2021 - 02:22 UTC
Update
The error rate when communicating with 365 calendars from our US data center has reduced significantly and overall background processing has returned to normal, though errors for 365 calendars remain higher than normal.

Microsoft have opened MO234433 "Unable to access multiple Microsoft 365 apps or services" which is potentially related to the errors we have observed.
Posted Jan 15, 2021 - 01:27 UTC
Identified
We are still seeing a high rate of errors when communicating with Microsoft 365 calendars. This is affecting all calls, not just push notification registration as previously reported.

Service may be returning to normal. We are continuing to monitor and take mitigating actions where possible.
Posted Jan 15, 2021 - 01:18 UTC
Update
We are seeing a high rate of errors when registering push notifications for 365 hosted calendars from our US data center.

These requests are timing out or being refused with "service unavailable" responses. We have taken steps to mitigate the effects of this on background processing.
Posted Jan 15, 2021 - 01:01 UTC
Investigating
We are currently investigating this issue.
Posted Jan 15, 2021 - 00:40 UTC
This incident affected: Background Processing and Major Calendar Providers (Microsoft 365).