Apple sync degraded
Incident Report for Cronofy
Resolved
At 15:58 UTC, communication between Cronofy and Apple began to timeout for a proportion of our requests. This quickly worsened, causing Apple calendar syncs to take several attempts.

A change was deployed to slow down the rate of communication with Apple to reduce the pressure on their API and to avoid service being impacted for other calendar providers.

At 16:50 UTC, we started to see most communication succeed again and monitored the situation until it had remained stable for 30 minutes.
At 17:20 UTC, we removed the rate-limiting and continued to monitor the situation.

Normal service has continued, so we are marking this incident as resolved.
If you have any queries, please contact us at support@cronofy.com
Posted Feb 14, 2023 - 17:40 UTC
Monitoring
Apple API traffic has recovered, and normal operation has resumed.
We are continuing to monitor the service.
Posted Feb 14, 2023 - 16:52 UTC
Identified
We are seeing an increase in connection errors to Apple's API globally. Apple sync is still operating in a degraded state.
We will update at 17:00 UTC.
Posted Feb 14, 2023 - 16:37 UTC
Investigating
We are seeing increased errors from Apple's calendar API since 16:00 UTC; we are investigating and taking mitigating action.
Posted Feb 14, 2023 - 16:14 UTC
This incident affected: Major Calendar Providers (Apple).