Degraded Outlook.com sync performance
Incident Report for Cronofy
Resolved
The performance of Outlook.com requests has stayed stable at levels in line with its usual performance for over an hour.

At 07:54 UTC we saw a sharp increase in the number of connections failing to Outlook.com, which lasted until 09:30 UTC. This may have caused some changes to take longer to sync. Due to recent issues with Microsoft platforms, we have monitored for an extended period before resolving this issue.

We will continue monitoring but we believe the issue has been resolved.
Posted Jun 06, 2023 - 11:19 UTC
Update
We're seeing some improvement in Outlook.com requests, but still with enough failures that we consider it to be in a degraded state. We're continuing to monitor the situation.
Posted Jun 06, 2023 - 10:32 UTC
Monitoring
We are currently experiencing degraded sync with Outlook.com. This is not having an impact on our overall system performance. We are closely monitoring the situation.
Posted Jun 06, 2023 - 08:47 UTC
This incident affected: Major Calendar Providers (Outlook.com).