Apple sync degraded
Incident Report for Cronofy
Resolved
At 07:47 UTC, we saw a sharp increase in the number of Service Unavailable errors being returned from Apple’s calendar servers across all of our data centers, causing sync operations to fail.

This was escalated to our engineering team, who investigated and found that no other calendar providers were affected and so the issue was likely not within our infrastructure. However, very few operations between Cronofy and Apple were succeeding.

At 08:20 UTC, we opened an incident, to mark Apple sync as degraded, as customers may have seen an increased delay in calendar sync.

This coincided with a sharp drop in the level of failed network calls, which returned to normal levels at 08:18 UTC.

The service stabilized and Cronofy automatically retried failed sync operations to reconcile calendars.

Over the next hour, we saw communications with Apple return to a mostly healthy state, though there were still occasional spikes in the number of errors. Cronofy continued to automatically retry failed operations, so impact on users was minimal.

At 09:15 UTC, these low numbers of errors decreased back to baseline levels and stayed there.
As we’ve now seen more than 30 minutes of completely healthy service, we are resolving the incident
Posted Nov 30, 2023 - 10:05 UTC
Update
We are still observing small numbers of errors. These are being automatically retried so the service is largely unaffected, and we are continuing to monitor.
Posted Nov 30, 2023 - 09:25 UTC
Update
We are still seeing occasional, smaller number of errors. These are being retried automatically by Cronofy and the service is largely unaffected. We are continuing to monitor error levels.
Posted Nov 30, 2023 - 08:50 UTC
Monitoring
We saw a rise in Service Unavailable errors from Apple's calendar servers between 07:46 UTC and 08:19 UTC.
Normal operation has resumed. Cronofy will automatically retry any failed communications with Apple, so no further intervention is required.
We are continuing to monitor the situation to be sure that the incident is over.
Posted Nov 30, 2023 - 08:29 UTC
Investigating
We are investigating unusually high numbers of errors when syncing Apple calendars.
Posted Nov 30, 2023 - 08:20 UTC
This incident affected: Major Calendar Providers (Apple).