Delayed Google calendar synchronization
Incident Report for Cronofy
Resolved
Notifications from Google appear to be being sent as normal again now.

Whilst we can draw an approximation of the current state of such a problem from the data we hold, it is not something we can monitor over time.

We plan to resolve that across all calendar providers, not just Google, to provide better insight in the future.
Posted Mar 18, 2019 - 23:16 UTC
Identified
There appears to be a significant delay (several minutes rather than seconds) between events being created or updated in Google calendars and Cronofy being notified of the changes.

The overall volume of notifications we are receiving are comparable week-on-week so it does not appear that we are not being sent notifications at all.

There is not a problem updating our systems once we receive notifications.

We are working to quantify the scale of the problem to the degree that is possible (it is difficult to know you have not received a notification when you should have).
Posted Mar 18, 2019 - 17:31 UTC
This incident affected: Major Calendar Providers (Google).