US data center database read replica lagging
Incident Report for Cronofy
Resolved
This incident has been resolved.
Posted May 07, 2019 - 23:49 UTC
Update
We are continuing to monitor for any further issues.
Posted May 07, 2019 - 23:24 UTC
Monitoring
Replica lag is back to normal levels (near zero) and we are continuing to monitor as all processing catches back up.

We will also review if there are any actions we need to take to ensure nothing has been missed or lost in the meantime (though that should not be the case).
Posted May 07, 2019 - 16:23 UTC
Investigating
Our read replica, used to serve portions of our workload, is lagging significantly behind the primary database. This may lead to stale results being returned from our API and slower synchronization than normal.

We are investigating and in contact with AWS to resolve the problem.
Posted May 07, 2019 - 15:32 UTC
This incident affected: API, Background Processing, and Developer Dashboard.