Error rates have remained at normal levels and we believe the issue is over.
After two increases in error rates, at 14:24 UTC and 14:45 UTC, Google sync has remained stable. A minority of sync operations failed and were retried, eventually completing successfully.
Posted Jul 03, 2025 - 16:07 UTC
Monitoring
Error rates are still low and sync is working as expected. We are continuing to monitor the situation.
Posted Jul 03, 2025 - 15:36 UTC
Update
The error rate has remained low, but we are still investigating and monitoring.
Posted Jul 03, 2025 - 15:24 UTC
Update
Error rates have again returned to normal, and were affecting a fairly small number of operations spread across many accounts. We're continuing to investigate to try and find a pattern.
Posted Jul 03, 2025 - 15:09 UTC
Investigating
We are seeing the issue recur and are continuing to investigate.
Posted Jul 03, 2025 - 14:50 UTC
Monitoring
The error rate has returned to normal. This does not align with any changes or operations on our side, and the error returned from Google suggests this may have been a temporary issue on their side. We are continuing to investigate to try and identify a root cause, as well as monitoring the situation for any further changes.
Posted Jul 03, 2025 - 14:47 UTC
Investigating
We are seeing a sudden increase in Google sync errors and are investigating.
Posted Jul 03, 2025 - 14:36 UTC
This incident affected: Major Calendar Providers (Google).