MS Teams Conferencing Failures

Incident Report for Cronofy

Update

We believe the root cause is a lack of generated URLs for a meeting when we call Microsoft Graph APIs. We are waiting for a response from Microsoft on the issue. Unfortunately the timing of this is out of our hands.
We are also working on alternative ways to provision Teams meetings, but this will not provide a short term fix.

We are continuing to work on finding a way to resolve, mitigate or provide an more reliable path to Teams provisioning. We will update this incident over the coming days as we make meaningful progress.
Posted Feb 11, 2026 - 14:59 UTC

Update

We've found some evidence that other users of the Microsoft Graph API are experiencing the same issue; we're looking for anything that may let us mitigate the impact and we're reaching out to Microsoft for support.
Posted Feb 11, 2026 - 13:31 UTC

Update

We are still investigating; we are capturing additional logs to help us narrow down the failing population. Some conferences are being provisioned after automatically retrying, but still not as many as we'd expect.
Posted Feb 11, 2026 - 12:54 UTC

Update

We are continuing to investigate - the issue is not impacting all customers but we are not yet seeing a pattern to the domains or events impacted.
Posted Feb 11, 2026 - 12:07 UTC

Investigating

We are investigating an elevated level of failures for provisioning MS Teams Conferencing.
Posted Feb 11, 2026 - 11:29 UTC
This incident affects: Major Calendar Providers (Microsoft 365).