Delayed Exchange Sync
Incident Report for Cronofy
Resolved
This incident has been resolved.
Posted Jan 18, 2017 - 17:14 UTC
Monitoring
We think we have identified and fixed the issue we are continuing to monitor
Posted Jan 18, 2017 - 16:55 UTC
Investigating
We're experiencing some issues syncing exchange events we are investigating the root cause
Posted Jan 18, 2017 - 15:53 UTC